re = /(?<=[0-9a-z*])(?=\|)|(?<=\|)(?=[0-9a-z*])/
str = '20.558**|50cos|0.5|20sin|20.55'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end