using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"df_table_YoY";
string input = @"abcdefghijklmnopqrst0123456789/+ABCDEFGH;";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}