#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)(?m)^\s*\d+\..*\R{2} # Get to the title" & @CRLF & _
"(?<title>[^\n]*(?:\n(?!\n)[^\n]*)*) # Get title" & @CRLF & _
"\R{2} # Get to the authors" & @CRLF & _
"[^\n]*(?:\n(?!\R)[^\R]*)* # Consume authors" & @CRLF & _
"(?<abstract>[^\[]*(?:\[(?!PubMed[ ]-[ ]indexed[ ]for[ ]MEDLINE\])[^\[]*)*) # Grab abstract"
Local $sString = "1. Br J Biomed Sci. 2015;72(3):93-101." & @CRLF & _
"" & @CRLF & _
"Effects of propofol and isoflurane on haemodynamics and the inflammatory response" & @CRLF & _
"in cardiopulmonary bypass surgery." & @CRLF & _
"" & @CRLF & _
"Sayed S, Idriss NK, Sayyedf HG, Ashry AA, Rafatt DM, Mohamed AO, Blann AD." & @CRLF & _
"" & @CRLF & _
"Cardiopulmonary bypass (CPB) causes reperfusion injury that when most severe is" & @CRLF & _
"clinically manifested as a systemic inflammatory response syndrome. The" & @CRLF & _
"anaesthetic propofol may have anti-inflammatory properties that may reduce such a" & @CRLF & _
"response. We hypothesised differing effects of propofol and isoflurane on" & @CRLF & _
"inflammatory markers in patients having CBR Forty patients undergoing elective" & @CRLF & _
"CPB were randomised to receive either propofol or isoflurane for maintenance of" & @CRLF & _
"anaesthesia. CRP, IL-6, IL-8, HIF-1α (ELISA), CD11 and CD18 expression (flow" & @CRLF & _
"cytometry), and haemoxygenase (HO-1) promoter polymorphisms (PCR/electrophoresis)" & @CRLF & _
"were measured before anaesthetic induction, 4 hours post-CPB, and 24 hours later." & @CRLF & _
"There were no differences in the 4 hours changes in CRP, IL-6, IL-8 or CD18" & @CRLF & _
"between the two groups, but those in the propofol group had higher HIF-1α (P =" & @CRLF & _
"0.016) and lower CD11 expression (P = 0.026). After 24 hours, compared to the" & @CRLF & _
"isoflurane group, the propofol group had significantly lower levels of CRP (P <" & @CRLF & _
"0.001), IL-6 (P < 0.001) and IL-8 (P < 0.001), with higher levels CD11 (P =" & @CRLF & _
"0.009) and CD18 (P = 0.002) expression. After 24 hours, patients on propofol had " & @CRLF & _
"increased expression of shorter HO-1 GT(n) repeats than patients on isoflurane (P" & @CRLF & _
"= 0.001). Use of propofol in CPB is associated with a less adverse inflammatory" & @CRLF & _
"profile than is isofluorane, and an increased up-regulation of HO-1. This" & @CRLF & _
"supports the hypothesis that propofol has anti-inflammatory activity." & @CRLF & _
"" & @CRLF & _
"PMID: 26510263 [PubMed - indexed for MEDLINE]" & @CRLF & _
"11. Br J Biomed Sci. 2015;72(3):93-101." & @CRLF & _
"" & @CRLF & _
"Effects of propofol and isoflurane on haemodynamics and the inflammatory response" & @CRLF & _
"in cardiopulmonary bypass surgery." & @CRLF & _
"" & @CRLF & _
"Sayed S, Idriss NK, Sayyedf HG, Ashry AA, Rafatt DM, Mohamed AO, Blann AD." & @CRLF & _
"" & @CRLF & _
"Cardiopulmonary bypass (CPB) causes reperfusion injury that when most severe is" & @CRLF & _
"clinically manifested as a systemic inflammatory response syndrome. The" & @CRLF & _
"anaesthetic propofol may have anti-inflammatory properties that may reduce such a" & @CRLF & _
"response. We hypothesised differing effects of propofol and isoflurane on" & @CRLF & _
"inflammatory markers in patients having CBR Forty patients undergoing elective" & @CRLF & _
"CPB were randomised to receive either propofol or isoflurane for maintenance of" & @CRLF & _
"anaesthesia. CRP, IL-6, IL-8, HIF-1α (ELISA), CD11 and CD18 expression (flow" & @CRLF & _
"cytometry), and haemoxygenase (HO-1) promoter polymorphisms (PCR/electrophoresis)" & @CRLF & _
"were measured before anaesthetic induction, 4 hours post-CPB, and 24 hours later." & @CRLF & _
"There were no differences in the 4 hours changes in CRP, IL-6, IL-8 or CD18" & @CRLF & _
"between the two groups, but those in the propofol group had higher HIF-1α (P =" & @CRLF & _
"0.016) and lower CD11 expression (P = 0.026). After 24 hours, compared to the" & @CRLF & _
"isoflurane group, the propofol group had significantly lower levels of CRP (P <" & @CRLF & _
"0.001), IL-6 (P < 0.001) and IL-8 (P < 0.001), with higher levels CD11 (P =" & @CRLF & _
"0.009) and CD18 (P = 0.002) expression. After 24 hours, patients on propofol had " & @CRLF & _
"increased expression of shorter HO-1 GT(n) repeats than patients on isoflurane (P" & @CRLF & _
"= 0.001). Use of propofol in CPB is associated with a less adverse inflammatory" & @CRLF & _
"profile than is isofluorane, and an increased up-regulation of HO-1. This" & @CRLF & _
"supports the hypothesis that propofol has anti-inflammatory activity." & @CRLF & _
"" & @CRLF & _
"PMID: 26510263 [PubMed - indexed for MEDLINE]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")