import re
regex = re.compile(r"^(?P<start>.*)\s(-|to)\s(?P<end>.*)$", flags=re.IGNORECASE | re.DOTALL)
test_str = "18/03/1989 to 19/10/2000"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")