package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m):[^/]+`)
var str = `https://www.oddsportal.com/search/:SKbpVP5K/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}