$re = '~:[^/]+~m';
$str = 'https://www.oddsportal.com/search/:SKbpVP5K/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);