#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\((?>\((?<open>)|[^\r\n()]+|\)(?<-open>))*(?(open)(?!))\)|\b(big)\b"
Local $sString = "Should Match: " & @CRLF & _
"I like big cakes" & @CRLF & _
"I like (big cakes" & @CRLF & _
"I like big) cakes" & @CRLF & _
"I like xx big xx cakes" & @CRLF & _
"I like ( xx big xx cakes" & @CRLF & _
"I like xx big xx) cakes" & @CRLF & _
"" & @CRLF & _
"Should not Match: " & @CRLF & _
"I like (big) cakes" & @CRLF & _
"I like (xx big xx) cakes" & @CRLF & _
"" & @CRLF & _
"I like (xx(test(big test big ( big ))) big xx) cakes" & @CRLF & _
"I like (xx(test(big test big ( big ))) big xx) big (xx(test(big test big ( big ))) big xx) cakes"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")