import Foundation
let pattern = #"\((?>\((?<open>)|[^\r\n()]+|\)(?<-open>))*(?(open)(?!))\)|\b(big)\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Should Match:
I like big cakes
I like (big cakes
I like big) cakes
I like xx big xx cakes
I like ( xx big xx cakes
I like xx big xx) cakes
Should not Match:
I like (big) cakes
I like (xx big xx) cakes
I like (xx(test(big test big ( big ))) big xx) cakes
I like (xx(test(big test big ( big ))) big xx) big (xx(test(big test big ( big ))) big xx) cakes
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)