#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?:^https?:\/\/|^)[^\/]*)"
Local $sString = "https://regex101.com/" & @CRLF & _
"https://regex101.com/httpsregex101.com/" & @CRLF & _
"regex101.com/" & @CRLF & _
"http://regex101.com/httpsregex101.com/" & @CRLF & _
"www.regex101.com/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")