import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:^https?:\\/\\/|^)[^\\/]*)";
final String string = "https://regex101.com/\n"
+ "https://regex101.com/httpsregex101.com/\n"
+ "regex101.com/\n"
+ "http://regex101.com/httpsregex101.com/\n"
+ "www.regex101.com/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}