$re = '/(\d{1,2},){1,10}[^,]/m';
$str = '10,2,3,5,1
1,10,3
20,3,1,4
300,123,123,13
1,3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);