re = /(\d{1,2},){1,10}[^,]/m
str = '10,2,3,5,1
1,10,3
20,3,1,4
300,123,123,13
1,3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end