re = /\b(?:https?:\/\/)(?:www\d?\.)?[-\w\d\/?\.=&\+]+\b/m
str = 'https://habibs.myportfolio.com
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end