#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\\((?:.(?!\\))+\.log)"
Local $sString = "input { " & @CRLF & _
" file {" & @CRLF & _
" path => "C:\tools\apache-tomcat-8.0.32\logs\abcd_access_log.2016-03-15.log"" & @CRLF & _
" start_position => beginning" & @CRLF & _
" } " & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"input { " & @CRLF & _
" file {" & @CRLF & _
" path => "C:\tools\apache-tomcat-8.0.32\logs\efgh_access_log.2016-02-16.log"" & @CRLF & _
" start_position => beginning" & @CRLF & _
" } " & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")