const regex = /\\((?:.(?!\\))+\.log)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\\((?:.(?!\\\\))+\\.log)', 'g')
const str = `input {
file {
path => "C:\\tools\\apache-tomcat-8.0.32\\logs\\abcd_access_log.2016-03-15.log"
start_position => beginning
}
}
input {
file {
path => "C:\\tools\\apache-tomcat-8.0.32\\logs\\efgh_access_log.2016-02-16.log"
start_position => beginning
}
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}