using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-z][a-z0-9-]*)=(?![ #])(((?![\\=""+,;<>]).)|(\\[ \\#=""+,;<>])|(\\[a-f0-9][a-f0-9]))*(,([a-z][a-z0-9-]*)=(?![ #])(((?![\\=""+,;<>]).)|(\\[ \\#=""+,;<>])|(\\[a-f0-9][a-f0-9]))*)*$";
string input = @"dc=kgfsl,dc=com";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}