$re = '/^([a-z][a-z0-9-]*)=(?![ #])(((?![\\\\="+,;<>]).)|(\\\\[ \\\\#="+,;<>])|(\\\\[a-f0-9][a-f0-9]))*(,([a-z][a-z0-9-]*)=(?![ #])(((?![\\\\="+,;<>]).)|(\\\\[ \\\\#="+,;<>])|(\\\\[a-f0-9][a-f0-9]))*)*$/';
$str = 'dc=kgfsl,dc=com';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);