import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!(?>[^A\\n]*A){4})(?!(?>[^P\\n]*P){3})(?!(?>[^L\\n]*L){2})(?!(?>[^E\\n]*E){2})(?!(?>[^S\\n]*S){2})[APLES]*$";
final String string = "APPLE\n"
+ "APPLES\n"
+ "PALE\n"
+ "ALE\n"
+ "APPPLE\n"
+ "APPLLE\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}