$re = '/^(?!(?>[^A\n]*A){4})(?!(?>[^P\n]*P){3})(?!(?>[^L\n]*L){2})(?!(?>[^E\n]*E){2})(?!(?>[^S\n]*S){2})[APLES]*$/m';
$str = 'APPLE
APPLES
PALE
ALE
APPPLE
APPLLE
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);