const regex = /(\d+)(?=м\b|\s+метров)/iug;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)(?=м\\b|\\s+метров)', 'iug')
const str = `Типа 10 метров.
А тут всего 9м.
Но не 8 м и не 7метров
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}