re = /(\d+)(?=м\b|\s+метров)/i
str = 'Типа 10 метров.
А тут всего 9м.
Но не 8 м и не 7метров
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end