const regex = /^(?=.{1,23}$)^\w+\s*(-?)(\s*\w+\s*)(\w+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.{1,23}$)^\\w+\\s*(-?)(\\s*\\w+\\s*)(\\w+)$', 'gm')
const str = `The cases I need to pass:
Winston1-Salem6
Winston-Salem
Winston Salem
1-two3
word2 with space
Cases I need to fail:
-Newberty-Los-
12345678901234567890123444
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}