re = /^(?=.{1,23}$)^\w+\s*(-?)(\s*\w+\s*)(\w+)$/m
str = 'The cases I need to pass:
Winston1-Salem6
Winston-Salem
Winston Salem
1-two3
word2 with space
Cases I need to fail:
-Newberty-Los-
12345678901234567890123444
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end