#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?!^.{24,}$)^\w+\s*(-?)(\s*\w+\s*)(\w+)$"
Local $sString = "The cases I need to pass:" & @CRLF & _
"Winston1-Salem6" & @CRLF & _
"Winston-Salem" & @CRLF & _
"Winston Salem" & @CRLF & _
"1-two3" & @CRLF & _
"word2 with space" & @CRLF & _
"" & @CRLF & _
"Cases I need to fail:" & @CRLF & _
"" & @CRLF & _
"-Newberty-Los-" & @CRLF & _
"12345678901234567890123444" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")