import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!^.{24,}$)^\\w+\\s*(-?)(\\s*\\w+\\s*)(\\w+)$";
final String string = "The cases I need to pass:\n"
+ "Winston1-Salem6\n"
+ "Winston-Salem\n"
+ "Winston Salem\n"
+ "1-two3\n"
+ "word2 with space\n\n"
+ "Cases I need to fail:\n\n"
+ "-Newberty-Los-\n"
+ "12345678901234567890123444\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}