package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`/page_[\s\S]+?/`)
var str = `http://my-domain.com/search/page_2/order_asc`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}