$re = '~/page_[\s\S]+?/~';
$str = 'http://my-domain.com/search/page_2/order_asc';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);