using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<p.*?>.*?<iframe.*?><\/iframe><\/p>";
string input = @"<p style=""text-align: center; "">
<iframe height=""360"" src=""http://example.com/videoembed/9338/"" frameborder=""0"" width=""640""></iframe></p>
<p style=""text-align: center;""><iframe allowfullscreen="" frameborder=""0"" height=""360"" src=""http://example.com/videoembed/9718/"" width=""640""></iframe></p>";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}