package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?is)<p.*?>.*?<iframe.*?><\/iframe><\/p>`)
var str = `<p style="text-align: center; ">
<iframe height="360" src="http://example.com/videoembed/9338/" frameborder="0" width="640"></iframe></p>
<p style="text-align: center;"><iframe allowfullscreen="" frameborder="0" height="360" src="http://example.com/videoembed/9718/" width="640"></iframe></p>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}