#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/path\/\d+">\K(?!.*img).*?(?=<\/a>)"
Local $sString = "<a href="/path/1232432432">Get Me</a>" & @CRLF & _
"<a href="/path/7845454354"><img src="imagelink.png" /></a>" & @CRLF & _
"<a href="#">Other link</a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")