using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/path\/\d+"">\K(?!.*img).*?(?=<\/a>)";
string input = @"<a href=""/path/1232432432"">Get Me</a>
<a href=""/path/7845454354""><img src=""imagelink.png"" /></a>
<a href=""#"">Other link</a>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}