const regex = /([A-Z])([0-9])[a-z]\2\1|([0-9])([A-Z])[a-z]\4\3/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([A-Z])([0-9])[a-z]\\2\\1|([0-9])([A-Z])[a-z]\\4\\3', 'g')
const str = `K2i2K
2KiK2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}