$re = '/([A-Z])([0-9])[a-z]\2\1|([0-9])([A-Z])[a-z]\4\3/';
$str = 'K2i2K
2KiK2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);