using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\24((?:.(?!\\24))*:.*?)\\24";
string input = @"\24s904dS\24sr4d2\24x\\y\\12z:234F\\3dRl\24o980\24foo:bar\24abcd";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}