const regex = /\\24((?:.(?!\\24))*:.*?)\\24/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\\24((?:.(?!\\\\24))*:.*?)\\\\24', 'g')
const str = `\\24s904dS\\24sr4d2\\24x\\\\y\\\\12z:234F\\\\3dRl\\24o980\\24foo:bar\\24abcd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}