$re = '/(?:[^`!@#$%^&*\-_=+\'/.,]*[`!@#$%^&*\-_=+\'/.,]){2}/';
$str = 'text 22 # and one more /';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);