$re = '/\d+\s+(.*?)\s+[A-Z]+/m';
$str = '312415 red, gree, yellow-white, snowy CDEFASE
29321093123 one, two, three #four IRUASJDJADALLDLA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);