re = /\d+\s+(.*?)\s+[A-Z]+/m
str = '312415 red, gree, yellow-white, snowy CDEFASE
29321093123 one, two, three #four IRUASJDJADALLDLA'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end