const regex = /global.*(timeout\s+http-request\s+\d+).*?defaults/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('global.*(timeout\\s+http-request\\s+\\d+).*?defaults', 's')
const str = `global
log 127.0.0.1 local0
log 127.0.0.1 local1 notice
#log loghost local0 info
maxconn 32768
tune.maxaccept -1
chroot /var/lib/haproxy
daemon
stats socket /var/run/haproxy.sock mode 600 level admin
stats timeout 2m
timeout http-request 5000
defaults
log global
mode http
option httplog
option dontlognull
retries 5
option redispatch
maxconn 16384
timeout connect 7s
timeout client 500s
timeout server 500s
timeout http-request 7000
timeout client-fin 30s
timeout tunnel 1h`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}