re = /global.*(timeout\s+http-request\s+\d+).*?defaults/
str = 'global
log 127.0.0.1 local0
log 127.0.0.1 local1 notice
#log loghost local0 info
maxconn 32768
tune.maxaccept -1
chroot /var/lib/haproxy
daemon
stats socket /var/run/haproxy.sock mode 600 level admin
stats timeout 2m
timeout http-request 5000
defaults
log global
mode http
option httplog
option dontlognull
retries 5
option redispatch
maxconn 16384
timeout connect 7s
timeout client 500s
timeout server 500s
timeout http-request 7000
timeout client-fin 30s
timeout tunnel 1h'
# Print the match result
str.match(re) do |match|
puts match.to_s
end