using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((.{2})(.)(.{1}))(\2.\4)(\2.\4)";
string input = @"AAxBAAyBAAzB";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}