$re = '/((.{2})(.)(.{1}))(\2.\4)(\2.\4)/';
$str = 'AAxBAAyBAAzB';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);