package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([a-z-]+)\/([a-z]+[-]*[a-z]+)-([a-zA-Z0-9]+[-]*[a-z0-9]+)\/?$`)
var str = `class-s/ford-shelby-gt350r
class-s/exotic-rides-w70`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}