re = /([a-z-]+)\/([a-z]+[-]*[a-z]+)-([a-zA-Z0-9]+[-]*[a-z0-9]+)\/?$/m
str = 'class-s/ford-shelby-gt350r
class-s/exotic-rides-w70'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end