re = /^(?:(?:\b([0-9]|[1-9][0-9])\b)(?:\.\b([0-9]|[1-9][0-9])\b)?|.\b([0-9]|[1-9][0-9])\b)$/m
str = '12
12.32
12
21.23
23.45
45.57
23.98
1.87
98.98'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end