// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:(?:\b([0-9]|[1-9][0-9])\b)(?:\.\b([0-9]|[1-9][0-9])\b)?|.\b([0-9]|[1-9][0-9])\b)$").unwrap();
let string = "12
12.32
12
21.23
23.45
45.57
23.98
1.87
98.98";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}