const regex = /\/(\d+)\-/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/(\\d+)\\-', '')
const str = `/user/1234-username`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);