use strict;
my $str = '/user/1234-username';
my $regex = qr/\/(\d+)\-/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";