#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\/(\d+)-"
Local $sString = "/user/1234-username"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)