using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/(\d+)-";
string substitution = @"$1";
string input = @"/user/1234-username";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}